0 815
php包管理器Composer的安装_图一

1、查看php版本

php -v

(如果你是编译安装的php没有php的命令,那么你可以做的软连接比如我的是编译安装在这个目录/usr/local/php7/

ln -s /usr/local/php7/bin/php /usr/local/bin/php)

运行 Composer 需要 PHP 5.3.2+ 以上版本,composer 支持windows、linux等多平台。

2、执行以下命令安装

在这之前你可以cd在一上目录里安装,执行以下的命令就会在这个目录里生成一个composer.phar文件

curl -sS https://getcomposer.org/installer | php

3、设置全局可以使用

mv composer.phar /usr/local/bin/composer

(composer.phar 是 Composer 的二进制文件。这是一个 PHAR 包(PHP 的归档),这是 PHP 的归档格式可以帮助用户在命令行中执行一些操作)

4、查看是否安装成功

composer -V

5、设置composer的国内镜像

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

(如果你不想配置了那就取消,不建议。命令是 composer config -g --unset repos.packagist)

6、//查看配置是否成功

composer config -gl

7、其他暂时用不到

当某些不可抗因素导致原镜像不能正常使用的时候,切换composer镜像

//1、切换源
composer config -g repo.packagist composer https://packagist.phpcomposer.com
//2、清除所有 package 缓存(此步奏选泽性操作)
composer clear-cache
//3、查看配置是否成功
composer config -gl


[分类]
[来源] http://erlangyun.com/p/id/261.html
[声明] 本站资源来自用户分享,如损害你的权益请联系客服QQ:120074275给予处理。