0 1752
linux 编译安装libwebp 版本超过0.5版本于1.0版本以上_图一


checking for libwebp >= 0.4.1... no

checking for libwebpmux >= 0.5.0 libwebpdemux >= 0.5.0... no



1、下载libwebp源码

https://github.com/webmproject/libwebp

./autogen.sh
./configure
sudo make

sudo make install

安装成功之后使用查看

cwebp -version

发现有这个问题

sudo cwebp -version

cwebp: error while loading shared libraries: libwebpdemux.so.2: cannot open shared object file: No such file or directory

这说明 /usr/lib/目录下没有libwebpdemux.so.2

那么你看看你的 /usr/local/lib/目录下有没有libwebpdemux.so.2

如果有那好办了,直接

ln -s /usr/local/lib/libwebpdemux.so.2 /usr/lib/libwebpdemux.so.2

缺什么so文件就补什么so文件就用以上方法补。


[分类]
[来源] http://erlangyun.com/p/id/258.html
[声明] 本站资源来自用户分享,如损害你的权益请联系客服QQ:120074275给予处理。